Savegame in progress error messages

Problems and solutions for installing or running FreeOrion, including discussion of bugs if needed before posting a bug report. For problems building from source, post in Compile.
Post Reply
Message
Author
User avatar
MatGB
Creative Contributor
Posts: 3310
Joined: Fri Jun 28, 2013 11:45 pm

Savegame in progress error messages

#1 Post by MatGB » Sun Jun 18, 2017 3:00 am

OK, immediately after my AI post I switched back and got this popup as I tried to move a ship
Screenshot_20170618_035530.png
Screenshot_20170618_035530.png (232.52 KiB) Viewed 785 times
I was able to move/interact with the top one, the bottom and the rest of the UI completely non responsive, note I hadn't tried to kill the app in any way. The only way I could then do anything was to select the 'quit to main menu' option on the top one, it took me back to the meny screen but the bottom dialogue was still there and blocked anything else from working, clicking it got me an already disconnected error.

Again, #1587 rebased onto master, both these errors started with this compile from today, never seen either before.
Mat Bowles

Any code or patches in anything posted here is released under the CC and GPL licences in use for the FO project.

User avatar
MatGB
Creative Contributor
Posts: 3310
Joined: Fri Jun 28, 2013 11:45 pm

Re: Savegame in progress error messages

#2 Post by MatGB » Sun Jun 18, 2017 3:42 am

Tried playing a few more turns, it eventually started doing this all the time, made the game unplayable, have now compiled a clean run from master to see if can replicate
ETA turn 5 of a clean compile from master.

I saved the game, quit and reloaded on turn 2, kept getting the AI errors from the other thread, on turn 5 got the above message, log not helpful

Code: Select all

04:44:59.411375 [debug] client : ScopedTimer.cpp:28 : RotatingPlanetControl::Refresh time:       54 ms
04:44:59.686276 [debug] client : HumanClientApp.cpp:1211 : HumanClientApp::ResetToIntro
04:44:59.686348 [debug] client : HumanClientApp.cpp:1216 : save game in progress. Checking with player.
04:44:59.701448 [debug] client : HumanClientApp.cpp:1211 : HumanClientApp::ResetToIntro
04:44:59.701533 [debug] client : HumanClientApp.cpp:1216 : save game in progress. Checking with player.
04:44:59.729632 [debug] network : ClientNetworking.cpp:477 : Client connection disconnected by EOF from server.
04:44:59.747877 [debug] client : HumanClientApp.cpp:1258 : HumanClientApp::DisconnectedFromServer
04:44:59.747960 [debug] client : HumanClientApp.cpp:1211 : HumanClientApp::ResetToIntro
04:44:59.747977 [debug] client : HumanClientApp.cpp:1216 : save game in progress. Checking with player.
04:45:27.732478 [debug] client : HumanClientApp.cpp:962 : HumanClientApp::HandleFocusChange(Lost Focus)
I clicked open a newly scouted system at the point this happened.
Mat Bowles

Any code or patches in anything posted here is released under the CC and GPL licences in use for the FO project.

User avatar
Vezzra
Release Manager, Design
Posts: 4745
Joined: Wed Nov 16, 2011 12:56 pm
Location: Sol III

Re: Savegame in progress error messages

#3 Post by Vezzra » Sun Jun 18, 2017 10:33 am

Can you try to narrow down which commit introduced the issue?

dbenage-cx
Programmer
Posts: 389
Joined: Sun Feb 14, 2016 12:08 am

Re: Savegame in progress error messages

#4 Post by dbenage-cx » Tue Jun 20, 2017 11:01 pm

Possibly unrelated, do you delete *.pyc files when switching branches? e.g.

Code: Select all

freeorion$ find . -name *.pyc -delete
Any content posted should be considered licensed GNU GPL 2.0 and/or CC-BY-SA 3.0 as appropriate.

User avatar
MatGB
Creative Contributor
Posts: 3310
Joined: Fri Jun 28, 2013 11:45 pm

Re: Savegame in progress error messages

#5 Post by MatGB » Tue Jun 20, 2017 11:15 pm

dbenage-cx wrote:Possibly unrelated, do you delete *.pyc files when switching branches? e.g.

Code: Select all

freeorion$ find . -name *.pyc -delete
No, didn't know you could do that at all, still not 100% sure what a pyc file is either, would doing that semi regularly help?
Mat Bowles

Any code or patches in anything posted here is released under the CC and GPL licences in use for the FO project.

dbenage-cx
Programmer
Posts: 389
Joined: Sun Feb 14, 2016 12:08 am

Re: Savegame in progress error messages

#6 Post by dbenage-cx » Tue Jun 20, 2017 11:42 pm

I tend to do it as a first step with troubleshooting any python related issue. It has been some time since, but it resolved at least one set of errors in the past.
.pyc are the compiled form of .py files (see related SO question, which should be regenerated when the source changes, but might not be (I picked up this tip from another thread here somewhere).

(wish there was an option to disable them, I've been playing with vfs and was tempted to merge python scripts to temporary directory for execution)
Any content posted should be considered licensed GNU GPL 2.0 and/or CC-BY-SA 3.0 as appropriate.

User avatar
em3
Vacuum Dragon
Posts: 527
Joined: Sun Sep 25, 2011 2:51 pm

Re: Savegame in progress error messages

#7 Post by em3 » Tue Jul 04, 2017 10:31 am

dbenage-cx wrote:(wish there was an option to disable them, I've been playing with vfs and was tempted to merge python scripts to temporary directory for execution)
https://stackoverflow.com/questions/154 ... -pyc-files
[...] for Man has earned his right to hold this planet against all comers, by virtue of occasionally producing someone totally batshit insane. - Randall Munroe, title text to xkcd #556

dbenage-cx
Programmer
Posts: 389
Joined: Sun Feb 14, 2016 12:08 am

Re: Savegame in progress error messages

#8 Post by dbenage-cx » Sat Jul 08, 2017 5:39 pm

Thank you em3, it was some time ago I last searched (with the object to redirect e.g. Way to have compiled python files in a separate folder).
The old issue was most likely after a python source file was removed (result from switching specific branches).

User avatar
em3
Vacuum Dragon
Posts: 527
Joined: Sun Sep 25, 2011 2:51 pm

Re: Savegame in progress error messages

#9 Post by em3 » Sun Jul 09, 2017 8:50 am

Glad to be of service. It's especially nice that it can be done using an environment variable, and thus with no alterations to the FO itself.
[...] for Man has earned his right to hold this planet against all comers, by virtue of occasionally producing someone totally batshit insane. - Randall Munroe, title text to xkcd #556

Thinker55
Space Krill
Posts: 6
Joined: Sat Jan 12, 2019 7:25 pm

Re: Savegame in progress error messages

#10 Post by Thinker55 » Sat Jan 12, 2019 7:44 pm

I'm getting this going into turn 5 no matter what I do. I'm on Build 4.7.1 on openSuSe LEAP 15. The system times out for a while, then reports "The connection to the server has been lost" I'm in single-player mode -- why would it be going to a server? Trying to reload an autosaved turn 4 leads straight to the "connection lost" message. Suggestions? There appears to be no update in any repository I have access to. I could try to compile, but this is a new build, so I might not have what I need. I tried changing the options per below -- no change.

User avatar
Geoff the Medio
Programming, Design, Admin
Posts: 12324
Joined: Wed Oct 08, 2003 1:33 am
Location: Munich

Re: Savegame in progress error messages

#11 Post by Geoff the Medio » Sat Jan 12, 2019 11:35 pm

Thinker55 wrote:
Sat Jan 12, 2019 7:44 pm
I'm in single-player mode -- why would it be going to a server?
In a single-player game, the server process is running on the same machine as the interface and AI processes.

User avatar
Oberlus
Juggernaut
Posts: 838
Joined: Mon Apr 10, 2017 4:25 pm

Re: Savegame in progress error messages

#12 Post by Oberlus » Sun Jan 13, 2019 1:44 pm

Thinker55 wrote:
Sat Jan 12, 2019 7:44 pm
I'm on Build 4.7.1
4.7.1 is already pretty "old". Since you are in Linux, I recommend downloading latest source code and compiling it yourself.

Thinker55
Space Krill
Posts: 6
Joined: Sat Jan 12, 2019 7:25 pm

Re: Savegame in progress error messages

#13 Post by Thinker55 » Sun Jan 13, 2019 5:02 pm

I did that. The latest build is working well for me.

Post Reply