Game doesn´t start on old ASUS Eee PC

Problems and solutions for installing or running FreeOrion, including discussion of bugs if needed before posting a bug report. For problems building from source, post in Compile.

Moderators: Oberlus, Oberlus

Post Reply
Message
Author
AK47
Space Krill
Posts: 2
Joined: Tue Oct 01, 2019 7:50 pm

Game doesn´t start on old ASUS Eee PC

#1 Post by AK47 » Tue Oct 01, 2019 8:19 pm

Hi, I´m new here, but I really would like to play this game.

I use an old ASUS EeePC Netbook (1005PE I guess), with an Intel Atom450 with MX Linux installed and I got the game via the Debian manager. So I got it installed, and I see the Icon to click it. But after a short increase in memory power, nothing happens. So I tried to start the game via console and this is what I got:

Code: Select all

$ freeorion
CWD: /usr/share/games/freeorion
Cannot connect to server socket err = No such file or directory
Cannot connect to server request channel
jack server is not running or cannot be started
JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for -1, skipping unlock
JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for -1, skipping unlock
Segmentation fault
I would be glad If you could help me, for this game really looks awesome and would perfectly fit my casual gaming needs.

User avatar
Geoff the Medio
Programming, Design, Admin
Posts: 12446
Joined: Wed Oct 08, 2003 1:33 am
Location: Munich

Re: Game doesn´t start on old ASUS Eee PC

#2 Post by Geoff the Medio » Tue Oct 01, 2019 11:35 pm

Please locate and post, possibly zipped if necessary or directly in the post text, freeorion.log from ~/.local/share/freeorion from immediately after failing to start the program.

Note that FreeOrion requires OpenGL 2.1, which is a likely cause of problems on old systems with low-power processors.

User avatar
Vezzra
Release Manager, Design
Posts: 5000
Joined: Wed Nov 16, 2011 12:56 pm
Location: Sol III

Re: Game doesn´t start on old ASUS Eee PC

#3 Post by Vezzra » Wed Oct 02, 2019 9:06 am

Although, judging by the error messages, it's not graphic related stuff that seems to be the issue here, but something that tries to connect to this ominous "jack server" (whatever that is), failing to succeed and then crashing with a segfault...

User avatar
Oberlus
Cosmic Dragon
Posts: 1489
Joined: Mon Apr 10, 2017 4:25 pm

Re: Game doesn´t start on old ASUS Eee PC

#4 Post by Oberlus » Wed Oct 02, 2019 11:27 am

Then maybe it is related to this older error (not FreeOrion fault): viewtopic.php?f=25&t=11096&p=93821&hili ... ror#p93821
Pleasepleaseplease, join fifth multiplayer slow game!

User avatar
Vezzra
Release Manager, Design
Posts: 5000
Joined: Wed Nov 16, 2011 12:56 pm
Location: Sol III

Re: Game doesn´t start on old ASUS Eee PC

#5 Post by Vezzra » Wed Oct 02, 2019 11:36 am

Yep, that's very likely the same issue. @AK47, take a look at the linked thread (you'll find a link to yet another thread there, which you probably should follow too), maybe you find something that can help you.

AK47
Space Krill
Posts: 2
Joined: Tue Oct 01, 2019 7:50 pm

Re: Game doesn´t start on old ASUS Eee PC

#6 Post by AK47 » Wed Oct 02, 2019 8:05 pm

Thanks for the quick replies! :D
So I noticed this
Well maybe I should have actually had a look at the Linux manual myself because this issue is actually somewhat referenced in the installation section. Well done me, doing it the hard way :)
Unfortunately I can´t find the readme Data for Linux.
I also couldn´t follow
I did was run 'qjackctl', under setup, settings, parameters, interface selected my audio device ('hw:Generic') because for some reason it wasn't selected by default. And under advanced, server prefix put 'pasuspsender --jackd'.
I already installed jackd.
Maybe you know where to find this readme manual for linux? Or does he mean the compiling manual. As a linux noob I never compiled anything, yet.
:oops:

User avatar
em3
Vacuum Dragon
Posts: 597
Joined: Sun Sep 25, 2011 2:51 pm

Re: Game doesn´t start on old ASUS Eee PC

#7 Post by em3 » Thu Oct 03, 2019 2:33 pm

Maybe here will be something useful to you:
https://askubuntu.com/questions/224151/ ... ctl/232163
[...] for Man has earned his right to hold this planet against all comers, by virtue of occasionally producing someone totally batshit insane. - Randall Munroe, title text to xkcd #556

User avatar
Vezzra
Release Manager, Design
Posts: 5000
Joined: Wed Nov 16, 2011 12:56 pm
Location: Sol III

Re: Game doesn´t start on old ASUS Eee PC

#8 Post by Vezzra » Fri Oct 04, 2019 9:32 am

@AK47, sorry, I'm out of my depth here...

User avatar
Geoff the Medio
Programming, Design, Admin
Posts: 12446
Joined: Wed Oct 08, 2003 1:33 am
Location: Munich

Re: Game doesn´t start on old ASUS Eee PC

#9 Post by Geoff the Medio » Fri Oct 04, 2019 12:07 pm

I think that, like last time this was reported, the issue wasn't really related to the Jack Audio stuff. See starting here: viewtopic.php?f=25&t=10666#p89900

AndrewW
Juggernaut
Posts: 785
Joined: Mon Feb 04, 2013 10:15 pm

Re: Game doesn´t start on old ASUS Eee PC

#10 Post by AndrewW » Fri Oct 04, 2019 3:40 pm

Geoff the Medio wrote:
Fri Oct 04, 2019 12:07 pm
I think that, like last time this was reported, the issue wasn't really related to the Jack Audio stuff. See starting here: viewtopic.php?f=25&t=10666#p89900
I remember that fun.

Post Reply