Old savegames can not be loaded after update

Problems and solutions for installing or running FreeOrion, including discussion of bugs if needed before posting a bug report. For problems building from source, post in Compile.

Moderators: Oberlus, Oberlus

Post Reply
Message
Author
lotekker
Space Krill
Posts: 5
Joined: Mon Dec 09, 2019 5:32 pm

Old savegames can not be loaded after update

#1 Post by lotekker » Mon Dec 09, 2019 5:56 pm

Hello everyone and everywhere,

I updated a few days ago FreeOrion to the actual version v0.4.9 ppa [build 2019-12-3.c0eb3bb] Cmake.
Since then my latest savegames don't load anymore, a black screen is shown.
I use MINT LINUX 18.3 64b with cinnamon on an phenom II with 4Gb ram. The older Version of FreeOrion (I don know which version it was) ran smooth.

My questions:

How do i get the Version of FreeOrion out of those old save files, with which they were saved?

How do i downstep the FreeOrion Installation to that older Version?

Thank you in advance

lotekker

User avatar
Oberlus
Cosmic Dragon
Posts: 1770
Joined: Mon Apr 10, 2017 4:25 pm

Re: Old savegames can not be loaded after update

#2 Post by Oberlus » Tue Dec 10, 2019 6:41 am

Hi, and welcome.
lotekker wrote:
Mon Dec 09, 2019 5:56 pm
How do i get the Version of FreeOrion out of those old save files, with which they were saved?
Look for "<freeorion_version>" on the .sav files (if they are not binary save files). It's on the very first lines of the file.
How do i downstep the FreeOrion Installation to that older Version?
Uninstall current version and install the older one. You could get the older version from GitHub or SourceForge. For Linux, you'll have to compile from source, I think.


A bit of advice: forget your older save files and enjoy the new features of current version starting a new game.

Ophiuchus
Programmer
Posts: 1089
Joined: Tue Sep 30, 2014 10:01 am
Location: Wall IV

Re: Old savegames can not be loaded after update

#3 Post by Ophiuchus » Tue Dec 10, 2019 11:42 am

Oberlus wrote:
Tue Dec 10, 2019 6:41 am
. For Linux, you'll have to compile from source, I think.
If you have snapd on your system i should be able to provide a build if you need it. If you do not know if you have snapd available please tell me the linux distribution and its version.

I would need to know the freeorion version.
Any code or patches in anything posted here is released under the CC and GPL licences in use for the FO project.

Furthermore, I propse... we should default to four combat rounds instead of three ...for the good of playerkind.

User avatar
Oberlus
Cosmic Dragon
Posts: 1770
Joined: Mon Apr 10, 2017 4:25 pm

Re: Old savegames can not be loaded after update

#4 Post by Oberlus » Tue Dec 10, 2019 12:20 pm

Ophiuchus wrote:
Tue Dec 10, 2019 11:42 am
please tell me the linux distribution and its version.
This?
lotekker wrote:
Mon Dec 09, 2019 5:56 pm
MINT LINUX 18.3 64b with cinnamon

lotekker
Space Krill
Posts: 5
Joined: Mon Dec 09, 2019 5:32 pm

Re: Old savegames can not be loaded after update

#5 Post by lotekker » Tue Dec 10, 2019 5:07 pm

Hello & thanks for your kind help.

my old savegames look in texteditor like crap (see attachment), seems binary, only few readable text, no version number detected.
The file is also quite big (33,5MB).

Snapd just installed.

And thank you for your advice to use the new version. I did it but felt not comfortable. The user interface was in the beginning not nice, fonts too big etc. much to adjust. Plus an, imho, unbalanced KI, enemies much too strong, Monsters too much etc.. I know, that i can adjust this and i will give the new version a chance.

The old savegame was about 650th turn and i was on a winning trail and had just learned a few things and wanted to finish it with the new knowledge.

Maybe you have a tip how to detect the old version.

Thank you very much for your help

lotekker
Attachments
savegame_FO.png
savegame_FO.png (7.12 KiB) Viewed 378 times

Ophiuchus
Programmer
Posts: 1089
Joined: Tue Sep 30, 2014 10:01 am
Location: Wall IV

Re: Old savegames can not be loaded after update

#6 Post by Ophiuchus » Wed Dec 11, 2019 10:32 am

lotekker wrote:
Tue Dec 10, 2019 5:07 pm
Maybe you have a tip how to detect the old version.
If you do not see something like 0.4.8 or 0.4.9 in the hex dump I cant help you there.

Did you start your game with the ppa/0.4.9 ? (Or do you have an idea when you started/last updated?).
If you did not start with the ppa you probably started with 0.4.8, you could simply try to load the game with 0.4.8 which is currently in the stable channel of the freeorion snap.

If that does not run, you could trying to search for freeorion in your apt logfiles to see what version was installed before(?)
Any code or patches in anything posted here is released under the CC and GPL licences in use for the FO project.

Furthermore, I propse... we should default to four combat rounds instead of three ...for the good of playerkind.

lotekker
Space Krill
Posts: 5
Joined: Mon Dec 09, 2019 5:32 pm

Re: Old savegames can not be loaded after update

#7 Post by lotekker » Wed Dec 11, 2019 5:15 pm

Hello Ophiuchus,

man, that was great! Log-Files! Free orion has its own! in the directory where the save-folder is.

The Version of the old savegame is 0.4.5.

Is it possible to install the old version of FO parallel to the new 0.4.9?

Thank you very much for your assistance & help.

lotekker

Ophiuchus
Programmer
Posts: 1089
Joined: Tue Sep 30, 2014 10:01 am
Location: Wall IV

Re: Old savegames can not be loaded after update

#8 Post by Ophiuchus » Thu Dec 12, 2019 6:45 am

lotekker wrote:
Wed Dec 11, 2019 5:15 pm
The Version of the old savegame is 0.4.5.

Is it possible to install the old version of FO parallel to the new 0.4.9?

Thank you very much for your assistance & help.

lotekker
Welcome :)

In lieu of a custom track on snapcraft I released a 0.4.5 build (snap revision 61) as a branch on snapcraft.io : channel stable/v0.4.5

As this is a branch channel - Note THIS WILL VANISH IN 30 DAYS (2020-01-11) and silently switch to stable channel.

Parallel installs are pretty new in snapd but should work. Also having a snap and a ppa based version along should not be a problem.

Try this please

Code: Select all

snap refresh freeorion --channel=stable/v0.4.5
Any code or patches in anything posted here is released under the CC and GPL licences in use for the FO project.

Furthermore, I propse... we should default to four combat rounds instead of three ...for the good of playerkind.

lotekker
Space Krill
Posts: 5
Joined: Mon Dec 09, 2019 5:32 pm

Re: Old savegames can not be loaded after update

#9 Post by lotekker » Thu Dec 12, 2019 5:46 pm

Hello Ophiuchus,

nice try:

snap refresh freeorion --channel=stable/v0.4.5 brought this: snap "freeorion" is not installed

and: snap install freeorion --channel=stable/v0.4.5 brought that:

error: cannot perform the following tasks:
- Ensure prerequisites for "freeorion" are available (no snap revision available as specified)

I am not familiar with snap concept, i'm sorry.

A small hint howto?

Greetings

lotekker

User avatar
Oberlus
Cosmic Dragon
Posts: 1770
Joined: Mon Apr 10, 2017 4:25 pm

Re: Old savegames can not be loaded after update

#10 Post by Oberlus » Fri Dec 13, 2019 1:24 am

I found this:

https://forum.odroid.com/viewtopic.php?f=91&t=16847
https://oph.mdrjr.net/meveric/other/freeorion/

Maybe it can help you if the snap doesn't work (no idea what prerequisites could be missing).

Ophiuchus
Programmer
Posts: 1089
Joined: Tue Sep 30, 2014 10:01 am
Location: Wall IV

Re: Old savegames can not be loaded after update

#11 Post by Ophiuchus » Fri Dec 13, 2019 11:12 am

Oberlus wrote:
Fri Dec 13, 2019 1:24 am
I found this:

https://forum.odroid.com/viewtopic.php?f=91&t=16847
https://oph.mdrjr.net/meveric/other/freeorion/

Maybe it can help you if the snap doesn't work (no idea what prerequisites could be missing).
Isnt odroid for android - not for linux?
Any code or patches in anything posted here is released under the CC and GPL licences in use for the FO project.

Furthermore, I propse... we should default to four combat rounds instead of three ...for the good of playerkind.

Ophiuchus
Programmer
Posts: 1089
Joined: Tue Sep 30, 2014 10:01 am
Location: Wall IV

Re: Old savegames can not be loaded after update

#12 Post by Ophiuchus » Fri Dec 13, 2019 11:31 am

lotekker wrote:
Thu Dec 12, 2019 5:46 pm
snap refresh freeorion --channel=stable/v0.4.5 brought this: snap "freeorion" is not installed

and: snap install freeorion --channel=stable/v0.4.5 brought that:

error: cannot perform the following tasks:
- Ensure prerequisites for "freeorion" are available (no snap revision available as specified)
Hm, did you run the install command as root/ via sudo?

Yes, refresh is for installed snaps. So install should have worked. I snap remove freeorion and used your command and it worked for me.
The only prerequisite i can think of is "core", but that should be on your system anyway.

Try

Code: Select all

freeorion install core
first, then install freeorion.
Else tell me the output of

Code: Select all

snap list
Maybe also

Code: Select all

snap warnings
could be helpful?

Else you need to hit snapcraft.io forums. Did you try to install anything else using snap? Try snap install freeorion without the channel info.

If that fails try a snap with know linuxmint 18.3 installs (the oldest mint freeorion snap install is linuxmint 19.2), e.g.

Code: Select all

snap install tmnationsforever
. If that does not work you probably have a general snap/snapd issue with your system.
Any code or patches in anything posted here is released under the CC and GPL licences in use for the FO project.

Furthermore, I propse... we should default to four combat rounds instead of three ...for the good of playerkind.

User avatar
Oberlus
Cosmic Dragon
Posts: 1770
Joined: Mon Apr 10, 2017 4:25 pm

Re: Old savegames can not be loaded after update

#13 Post by Oberlus » Fri Dec 13, 2019 12:24 pm

Ophiuchus wrote:
Fri Dec 13, 2019 11:12 am
Isnt odroid for android - not for linux?
I had no idea what I was posting :lol:
I read there "Debian Jessie" and just thought of Linux (I was searching for: FreeOrion 0.4.5 prerequisites linux).

lotekker
Space Krill
Posts: 5
Joined: Mon Dec 09, 2019 5:32 pm

Re: Old savegames can not be loaded after update

#14 Post by lotekker » Fri Dec 13, 2019 5:32 pm

Hello everybody,
Hm, did you run the install command as root/ via sudo?
Nope. Good hint.

Now i did, reply: snap "freeorion" is already installed, see 'snap help refresh'. wow.
Then: sudo snap refresh freeorion --channel=stable/v0.4.5 --> freeorion (stable/v0.4.5) 0.4.5 from A333 (agrrr3) refreshed. Done!

Thank you very much for your help.

And ther are two icons inthe Games menu one slightly bigger than the other
Problem solved.

Kind regards

lotekker

Post Reply