UI bug in main window

Programmers discuss here anything related to FreeOrion programming. Primarily for the developers to discuss.

Moderators: Committer, Committer

Post Reply
Message
Author
gonse
Space Krill
Posts: 6
Joined: Mon Jun 08, 2020 8:20 pm

UI bug in main window

#1 Post by gonse » Mon Jun 08, 2020 8:31 pm

Hello, since some days e.g. the ship build icon in the upper menu bar can't be reached anymore. See the attached picture.
My resolution is 1280x1024 and this happens in window mode as well as in fullscreen.

User avatar
Oberlus
Cosmic Dragon
Posts: 2694
Joined: Mon Apr 10, 2017 4:25 pm

Re: UI bug in main window

#2 Post by Oberlus » Mon Jun 08, 2020 9:08 pm

There is no attached screenshot.

User avatar
Geoff the Medio
Programming, Design, Admin
Posts: 12675
Joined: Wed Oct 08, 2003 1:33 am
Location: Munich

Re: UI bug in main window

#3 Post by Geoff the Medio » Mon Jun 08, 2020 9:12 pm

Your picture didn't attach, but I assume it's related to the extra icon added for influence and tweaks to the toolbar layout. It will be fixed, but my initial attempts to do so nicely within the existing framework didn't work well.

gonse
Space Krill
Posts: 6
Joined: Mon Jun 08, 2020 8:20 pm

Re: UI bug in main window

#4 Post by gonse » Wed Jun 10, 2020 7:27 pm

Issue fixed with today's build. Thanks.

User avatar
Geoff the Medio
Programming, Design, Admin
Posts: 12675
Joined: Wed Oct 08, 2003 1:33 am
Location: Munich

Re: UI bug in main window

#5 Post by Geoff the Medio » Wed Jun 10, 2020 7:42 pm

gonse wrote:
Wed Jun 10, 2020 7:27 pm
Issue fixed with today's build. Thanks.
Sort of... the whole toolbar layout needs redoing with a custom solution. The GG::Layout functionality just isn't adequate for something this complicated...

Post Reply